Помогите пожалуйста написать программу в паскале "дано целое число N (>0). Найти...

0 голосов
25 просмотров

Помогите пожалуйста написать программу в паскале "дано целое число N (>0). Найти наибольшее целое число К, квадрат которого не превосходит N : K^2 <= N. функцию извлечения квадратного корня не использовать. " (используя оператор while) ребята, ВЫРУЧАЙТЕ!!!!


Информатика (235 баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var N,k:integer;
begin
  writeln('введите N');
  readln(N); K:=n div 2;
  while k*k>N do
    k:=k-1;
  writeln(k);
end.
{Возможны и другие варианты}

(846 баллов)