Напишите программу для записи в файл десяти чисел вводимых с клавиатуры.

0 голосов
74 просмотров

Напишите программу для записи в файл десяти чисел вводимых с клавиатуры.


Информатика (66 баллов) | 74 просмотров
0

паскаль, плюсы?

0

паскаль.

0

а прога должна делать?

0

да программа нужна и должна решаться на паскале.

Дано ответов: 2
0 голосов
Правильный ответ

Var f:text ;
c:array [1..10] of integer;
i:integer;
begin
for i:=1 to 10 do begin 
writeln ('Введите ',i,' число');
read(c[i]);
end;
assign (f,'res.txt');
rewrite(f);
for i:=1 to 10 do
write (f,' ',c[i]);
close (f);
end.

Писал на Pascal ABC. Для того, чтобы работала, тебе нужно создать папку, и в этой папке сохранить данную программу. После запуска, тебе нужно будет ввести 10 чисел. Результат сохранится в той папке, в которой будет сохранена программа !

(996 баллов)
0

Или же в 9 строчке указывай подробный путь, в какую папку нужно сохранить файл.

0 голосов

Var
  i, temp :integer;
begin
  assign(output, 'output.txt'); rewrite(output);
  for i to 10 do begin
    read(temp);
    write(temp);
  end;
end.
файл output.txt должен быть создан. 

(2.9k баллов)