Паскаль. Написать программу при помощи процедуры, которая по известному радиусу...

0 голосов
24 просмотров

Паскаль. Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Входящие данные: R (радиус);
Выходящие данные: S (площадь), L (длина окружности)


Информатика (19 баллов) | 24 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program primer;const Pi=3.14;
procedure SandL(R: integer; var S,L: real);
begin
   S:=Pi*Power(R,2);      L:=2*R*Pi;   end;
var R: integer;
S,L: real;
Begin
readln(R);
SandL(r,s,l);
writeln(Trunc(s),' ',Trunc(l));
end.
ABC Pascal

(724 баллов)
0

В Pascal ABC нет нужды задавать Pi - эта константа уже определена.