СРОЧНО!!!35 баллов напишите программу которая вводит с клавиатуры 10 чисел и вычисляет их...

0 голосов
60 просмотров

СРОЧНО!!!35 баллов
напишите программу которая вводит с клавиатуры 10 чисел и вычисляет их сумму и произведение ( паскаль )


Информатика (140 баллов) | 60 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Const n=10;
var   
a:array[1..n] of integer;
   i,sum,pr:integer;
begin
  pr:=1;
  for i:=1 to n do
    begin
     read(a[i]);
      sum+=a[i];
        pr*=a[i];
   end;
write('произведение равно:',pr,' сумма равна:', sum);
end.

(1.1k баллов)
0 голосов

Var:a1,a2,a3,a4,a5,a6,a7,a8,a9,a10,b1,b2:integer;
begin
readln(a1,a2,a3,a4,a5,a6,a7,a8,a9,a10);
b1:=a1+a2+a3+a4+a5+a6+a7+a8+a9+a10;
writeln(b1);
b2:=a1*a2*a3*a4*a5*a6*a7*a8*a9*a10;
write(b2);
end.

(110 баллов)
0

А если с циклом как бы выглядело 'тело цикла'?

0

А надо было писать в задании, что нужен цикл, массив и т.п. А сейчас Вам написали формально совершенно верное решение.

0

Ну если ты знаешь добавь ещё 1 ответ и качестве награды отмечу как лучший

0

Во-первых, оставьте эту глупую привычку "тыкать" незнакомым людям. А во-вторых, не надо мне указывать, чем заниматься.

0

ты сам начал этот наезд

0

Разъяснение Вам Правил Сервиса Вы считаете наездом? Ваше право. Ответ не требуется.

0

Вообще к Вам всего лишь обратились на "ты", ошибочно приняв за школьника(а таковых большинство). Я не вижу в этом ничего особенного.