Написать программу вывода ** экран чисел, если они чётные и индексы их ячеек чётные.

0 голосов
36 просмотров

Написать программу вывода на экран чисел, если они чётные и индексы их ячеек чётные.


Информатика (15 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a: array [1..1000]of integer;
     i,n:integer;

begin
Write('Размер массива N = ');
readln(n);

for i:= 1 to n do begin
write('a[',i,'] = ');
readln(a[i]);
end;

writeln;
for i:= 1 to n do
    if (i mod 2 = 0) and (a[i] mod 2 = 0) then
    write(a[i], '  ');
end.

(9.6k баллов)
0

А можно как то без "Program prog" и "Uses crt"?

0

Будет все точно также, начиная с var.

0

А без двух End.'ов?

0

Без эндов не пойдет. Можно убрать только один.

var a: array [1..1000]of integer;
i,n:integer;
begin
Write('Размер массива N = ');
readln(n);
for i:= 1 to n do
readln(a[i]);
writeln;
for i:= 1 to n do
if (i mod 2 = 0) and (a[i] mod 2 = 0) then
write(a[i], ' ');
end.

0

Красава