Напишите программу, которая получает два целых числа и находит их произведение, не...

0 голосов
101 просмотров

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными. Через цикл WHILE!!!!


Информатика (51 баллов) | 101 просмотров
0

на каком языке писать?

0

на английском

0

омг, языке программирования

0

да

0

рукалицо

Дан 1 ответ
0 голосов

{Возможно это можно более просто организовать, однако программа работает :) }
Var a,b,ax,x: integer; flag: boolean;
Begin
Readln(a,b); ax:=a;
If (a>=0) and (b>=0) then flag:=true
else begin a:=abs(a); b:=abs(b); flag:=false; end;
If (a=0) or (b=0) then write('0')
else begin while b > 1 do
begin a:=a+ax; dec(b); end; x:=a;
if flag then write(x) else write(x-x*2); end;
End.

(1.1k баллов)