Написать программу ** Паскале,которая выведет ** экран те строки из текстового файла,...

0 голосов
69 просмотров

Написать программу на Паскале,которая выведет на экран те строки из текстового файла, которые являются палиндромами. Имя файла вводить с клавиатуры.


Информатика (91 баллов) | 69 просмотров
Дан 1 ответ
0 голосов

Program proga_25_3;
var
 A: text;
s,p : string; 
i:integer;
 f:boolean;
begin 
  write('Введите имя и путь к файлу   '); 
  read(p); 
 assign(A, p); 
 reset(A);   
while not eof(A) do   
 begin       
 readln(A,s);                  
for i:=1 to length(s) div 2 do       
  if s[i]=s[length(s)-i+1] then          
 f:=true        
 else         
begin       
 f:=false;       
 break;       
 end;     
 if f then      
  writeln (S);   
 end;   
 close(A);
end.

(30 баллов)