ПОМОГИТЕ ПОЖАЛУЙСТА, ОЧЕНЬ ПРОШУ. 1)Составте программу в Паскаль. приписать по 1 в...

0 голосов
106 просмотров

ПОМОГИТЕ ПОЖАЛУЙСТА, ОЧЕНЬ ПРОШУ.
1)Составте программу в Паскаль. приписать по 1 в начало и в конец записи числа n (было n=3456, стало n=134561).
2) найти все двузначные числа, которые числа которые делятся на m или содержат цифру m.
3) Составить программу, которая прибавляет ко всем элементам массива по единице ,если массив заполняется с клавиатуры.


Информатика (111 баллов) | 106 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)
var a:integer;
begin
writeln('введите число');
readln(a);
writeln('1',a,'1');
end.
2)
var a,b,c:integer;
begin
writeln('введите число');
readln(a);
for c:=10 to 99 do
begin
if (c mod a = 0)  or (a = c mod 10) or (a = c div 10) then
writeln(c);
end;
end.
3) 
var b,c:integer;
a:array [1..100] of integer;
beginwriteln('введите длину массива');
readln(b);
for c:=1 to b do
begin
writeln('введите элемент массива');
readln(a[c]);
a[c]:=a[c]+1;
writeln(a[c]);
end;
end.

(8.6k баллов)
0

спасибо

0

вы не могли бы поставить лучший ответ? :D

0

Я не могу, у меня нет значка! может потом появится, то я обязательно поставлю

0

Я не могу, у меня нет значка! может потом появится, то я обязательно поставлю

0

спасибо :D