Нужно составить программу Паскаль с for вывести ** экран 1000;900;..;100

0 голосов
26 просмотров

Нужно составить программу Паскаль с for
вывести на экран 1000;900;..;100


Информатика (53 баллов) | 26 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// Нужно составить программу Паскаль с for вывести на экран 1000;900;..;100 

Var i,x:word;
begin
   for i:=1000 downto 100  do //Если вместо слова to в цикле for поставить downto, то после выполнения каждого шага цикла переменная-счетчик будет не увеличиваться, а уменьшаться на единицу   
begin

       x:= i mod 100;
       if x=0 then writeln (i);
     end;
end.


(31.5k баллов)
0 голосов

Var
   i,a : integer;
begin
a := 1100;
for i := 1 to 10 do
 begin
  a := a -100;
  writeln (a); // write (a,'; ');
end;
end.

(2.6k баллов)