Написать программу,которая вычисляет среднее арифметическое ненулевых элементов...

0 голосов
112 просмотров

Написать программу,которая вычисляет среднее арифметическое ненулевых элементов введенного с клавиатуры массива из 10 целых чисел. Помогите пожалуйста,плохо понимаю эти программы(((


Информатика (34 баллов) | 112 просмотров
Дан 1 ответ
0 голосов

Var a:array [1..10] of integer;
    i,count:integer;
    s:real;
begin
....//тут ты заполняешь массив как тебе надо
s:=0;
count:=0;
for i:=1 to 10 do begin
  if a[i]<>0 then begin  //если элемент ненулевой то
    s:=s+s;             //суммируем их и увеличиваем счетчик на 1
    count:=count+1;
  end;
end;
s:=s/count;
writeln('Среднее значение=', s:0:0);
end.

(227 баллов)