Помогите написать программу ** PascalABCNET Определите, сколько различных букв латинского...

0 голосов
89 просмотров

Помогите написать программу на PascalABCNET

Определите, сколько различных букв латинского алфавита встречается в строке. Регистр не учитывайте ('A' и 'a' — это одна и та же буква).

ВХОДНЫЕ ДАННЫЕ

Вводится строка, содержащая буквы латинского алфавита, пробелы, знаки препинания. Буквы могут быть как заглавные, так и строчные.

ВЫХОДНЫЕ ДАННЫЕ

Выведите одно число — количество различных букв в этой строке.


image

Информатика (94 баллов) | 89 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

См. файл во вложении


Скачать вложение Текст (TXT)
(2.0k баллов)
0

Partial Solution. Your score is = 3, 3/5 tests passed

0

Откуда взялся разрыв между 90 и 97?
for i := 65 to 90 do
high[i] := false;
for i := 97 to 122 do
low[i] := false;

0

var
a,b: array [1..10000] of integer;
z,i,j,n: integer;

begin
readln(n);
for i:=1 to N do
read(a[i]);

for i:=1 to n do
begin
z:=0;
for j:=1 to n do
if a[i]=a[j] then inc(z);
if z=1 then b[i]:=a[i];
end;

for i:=n downto 2 do
for j:=1 to i-1 do
if b[j+1] Swap(b[j+1],b[j]);

for i:=1 to N do
if b[i]<>0 then write(b[i],' ');
writeln;
end.