Срочно!!! Напишите программу, которая вводит натуральные числа A и N и вычисляет A^N. (...

0 голосов
137 просмотров

Срочно!!!
Напишите программу, которая вводит натуральные числа A и N и вычисляет A^N.
( С использованием цикла (если это вообще применимо)).


Информатика (140 баллов) | 137 просмотров
Дан 1 ответ
0 голосов

Function Power(x,y:real):real;
begin
  if x=0 then
    Power:=0
  else
    if x>0 then
      Power:=exp(ln(x)*y)
    else
      Power:=-exp(ln(abs(x))*y);
end;
 
var
 x,y:real;
begin
 readln(x,y);
 writeln(power(x,y));
end.

(83 баллов)