Чему равна переменная s ** выходе программы если ** входе подали n=121 в ответе укажите...

0 голосов
64 просмотров

Чему равна переменная s на выходе программы если на входе подали n=121 в ответе укажите число



var n,s,d:integer;
begin
readln(n);
s:=1; d:=2;
while n>=d do
begin
if (n mod d)=0 then s;=s+d;
d:=d+1;
end;
writeln(s);
end.


Другие предметы (549 баллов) | 64 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Как я понял, s - это сумма всех делителей числа 121(включая 1).
121=11*11
s=1+11+121=133
ответ:133

(11.8k баллов)
0

спасибо, за ответ, но мне казалось число будет больше

0

нет, это 100%-ный ответ:)попробуйте даже написать программу в Pascal, такой же ответ получите)

0

в этой задаче просят найти сумму всех делителей числа 121. а сумма всех делителей числа 121 равна 133

0

хорошо спасибо большое

0

вся суть в том, что 121=11*11. всего 3 делителя:)было бы там число например 144, то получили бы 403)

0

не смущайтесь по поводу этого)

0

пожалуйста:)