Напишите программу, которая вводит два целых числа и находит их произведение, не ис пользуя операцию умножения. Учтите, что числа могут быть отрицательными. ( Паскаль)
Var a, b, i, p: integer; begin writeln('Введите два целых числа'); readln(a, b); p := 0; for i := 1 to abs(b) do p := p + abs(a); writeln('Произведение = ', p); end.