Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено...

0 голосов
532 просмотров

Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. В конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0)


Информатика (15 баллов) | 532 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

{с клавиатуры вводится число a, до тех пор, пока не будет введен 0. Начальное введенное a записывается в min  и max, чтобы потом в цикле было с чем сравнивать}
var
min,max,a:real;
begin
   readln(a);
   min:=a;max:=a;
    while a<>0 do
        begin
             readln(a);
                 if a>max then
                     max:=a;
                 if a                      min:=a;
         end;
writeln('min: ',min,'  max: ',max);
end.

(9.6k баллов)