1)Напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов...

0 голосов
819 просмотров

1)Напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b .

Входные данные
Входная строк содержит два натуральных числа – границы диапазона a и b . Гарантируется, что a ≤ b .

Выходные данные
Программа должна вывести одно число – сумму квадратов натуральных чисел из диапазона [ a , b ] .

2)Напишите программу, которая вводит четыре натуральных числа (a, b, c и d) и находит все пятизначные числа, которые при делении на a дают в остатке b , а при делении на c дают в остатке d .

Входные данные
Первая входная строка содержит два натуральных числа, разделённые пробелами: a и b. Вторая строка содержит натуральные числа c и d, также разделённые пробелом. Гарантируется, что 0 ≤ b ≤ a и 0 ≤ d ≤ c.

Выходные данные
Программа должна вывести в одну строчку через пробел все пятизначные натуральные числа, которые при делении на a дают в остатке b, а при делении на c дают в остатке d . Если таких чисел нет, программа должна вывести число -1.


Информатика (166 баллов) | 819 просмотров
0

Ясное дело. потому я такие задания и не решаю, чтобы лентяям не помогать.

0

Задачи-то все на одну тему....

0

У большинства тупое кредо "А мне это не пригодится!"

0

У меня как раз сейчас в частном порядке обучаются три взрослых "тётки" - врач, юрист и бухгалтер, которые тоже так думали в школе.

0

Причем изучают именно программирование!

Дан 1 ответ
0 голосов
Правильный ответ

Обычно решают на Pascal, но я напишу на C++, он мне роднее)). Я конечно немножко по-другому реализовал (в плане ввода значений), но поставленную задачу выполняет.
1)
#include
#inlcude
#include
using namespace std;
int main()
{
 long a, b, i, sum=0;
 cin>>a; // Вводишь число a
 cin>>b; // Вводишь число b
  for (i=a;i<=b;i++)<br>    {
      sum=sum+(i*i);
    }
 cout<<sum; // выводим сумму квадратов чисел<br> _getch();
}

2)
#include
#inlcude
#include
using namespace std;
int main()
{
 long a,b,c,d,i;
 bool z=false;
 cin>>a;
 cin>>b;
 cin>>c;
 cin>>d;
 for (i=10000; i<=99999; i++) <br> {
   if (i % a==b && i % c==d) {z=true; cout<<i<<" ";}<br> }
 if (z==false) {cout<<"-1";} // Выводится если нет чисел<br>_getch();
}








(120 баллов)
0

Ошибка. В задаче сказано "при делении на a дают в остатке b , а при делении на c дают в остатке d ", т.е. тут надо одновременное выполнение обоих условий, а не два разных цикла.