«A»: Напишите программу, которая получает два целых числа A и B (0 < A < B) и выводит...

0 голосов
1.2k просмотров

«A»: Напишите программу, которая получает два целых числа A и B (0 < A < B) и выводит квадраты всех натуральных чисел в интервале от A до B.( Через цикл WHILE!!!!)
Пример:
Введите два целых числа:
10 12
10*10=100
11*11=121
12*12=144


Информатика (51 баллов) | 1.2k просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a, b: integer;
begin 
 repeat 
  writeln ('Введите два целых числа:'); 
  readln (a,b); 
  if (a<0) or (a>b) then writeln ('Ошибка') 
 until (a>0) and (b>a); 
 while a<=b do begin  <br>  writeln (a,'*',a,'=',a*a); 
  a:=a+1; 
 end;
end.

(94.9k баллов)
0 голосов

//PascalABC.NET версия 3.3.1590 от 03.12.2017
//Если программа не запускается, то обновите версию

var
    A, B: integer;

begin
    readln(A, B);
//    Assert((A > 0) and (A < B), 'не верные параметры'); //проверка на дурака если надо
    
    while A <= B do<br>    begin
        writeln('Квадрат числа ', A, ' = ', A * A);
        A := A + 1;
    end;
end.

(55.0k баллов)