Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20...

0 голосов
268 просмотров
Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20 учеников класса. В начале списка перечислены все пятерки, затем все остальные оценки. Сколько учеников имеют по информатике оценку пять?Условный оператор не использовать.
2)Составить программу, которая находит минимальное число большее 200, которое нацело делится на 17. Использовать цикл с предусловием While.всю программу напишите, пожалуйста)))

Информатика (133 баллов) | 268 просмотров
Дан 1 ответ
0 голосов

program class;
var a:array[1..20]of integer;
i,sum:integer;
begin
for i:=1 to 20 do
read(a[i]);
for i:=1 to 20 do
//так как нельзя юзать IF, сделаем так

sum:=sum+a[i] div 5; // Если 5, то +1, если меньше +0;
writeln('otlichnikov',sum);
end.

(4.6k баллов)