Написать программу, которая проверяет, находится ли введенное с клавиатуры число в...

0 голосов
76 просмотров

Написать программу, которая проверяет, находится ли введенное с клавиатуры число в массиве. Массив также должен вводится во время программы.


Информатика (15 баллов) | 76 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
   max= 10; // Количество элементов в массиве
var
   a:array [1..max]
   i,m:integer;
begin
   write('Введите',max,'чисел');
   for i:=1 to max do
      read(a[i])
   write('Введите число');
   read(m);
   for i:=1 to max do
      begin
         if a[i] = m 
            then
               begin
                  write('Это число есть в массиве');
                  exit
               end;
      end;
write('Этого числа нет в массиве')
end.

(242 баллов)