Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20...

0 голосов
260 просмотров

Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20 учеников класса. В начале списка перечислены все пятерки, затем все остальные оценки. Сколько учеников имеют по информатике оценку пять?Условный оператор не использовать. 2)Составить программу, которая находит минимальное число большее 200, которое нацело делится на 17. Использовать цикл с предусловием While.всю программу напишите, пожалуйста)))


Информатика (133 баллов) | 260 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

задача 1

program z1;

var a:array[1..20]of byte;
i,kol:b1yte;
begin
for i:=1 to 20 do
read(a[i]);
for i:=1 to 20 do
if a[i]=5 then kol:=kol+1;
writeln('otlichnikov=',kol);
end.

 

задача 2

program nacelo;
var i:integer;
begin
i:=200;
while i mod 17<>0 do
begin
i:=i+1;
end;
writeln(i);
end.

(14.6k баллов)