Программа в паскаль Написать программу, которая упорядочивает цифры в заданном...

0 голосов
94 просмотров

Программа в паскаль

Написать программу, которая упорядочивает цифры в заданном пятизначном числе по убыванию.


Информатика (15 баллов) | 94 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Написать программу, которая упорядочивает цифры в заданном пятизначном числе по убыванию.

var a:array[1..5] of integer;
x,i,j:integer;
begin
  Writeln('Введите пятизначное число');
  Readln (x);
  while  (x<9999) or (x>99999) do  // проверка числа на "пятизначность"
    begin
      writeln ('Вы ввели не пятизначное число попробуйте еще раз');
      readln (x);
    end;
  for i:=1 to 5 do //раскладываем число на отдельные цифры
    begin
      a[i]:=x mod 10;
      x:=x div 10;
    end;
    for j:=1 to 4 do //сортировка пузырьком
      begin
        for i:=1 to 4-j do
          begin
            if a[i]>a[i+1] then
              begin
                x:=a[i];
                a[i]:=a[i+1];
                a[i+1]:=x;
              end;
          end;
      end;
   for j:=1 to 5 do write (a[j]);//вывод результата
end.

(31.5k баллов)