Написать программу, которая заменяет все заглавные буквы строчными, а строчные –...

0 голосов
71 просмотров

Написать программу, которая заменяет все заглавные буквы строчными, а строчные – заглавными в заданной символьной строке. (Паскаль)


Информатика (12 баллов) | 71 просмотров
Дан 1 ответ
0 голосов

Program X; //работает только для русских строк
var   
    i: longint;   
    s: string;
begin
    readln(s);
    for i := 1 to length(s) do
        if (ord(s[i]) >= 192) and (ord(s[i]) <= 223) then<br>            s[i] := chr(ord(s[i]) + 32)
        else if (ord(s[i]) >= 224) and (ord(s[i]) <= 255) then<br>            s[i] := chr(ord(s[i]) - 32);
    writeln(s)
end.

(1.4k баллов)