Program z6_2; uses crt; const n=6; var a:array[1..6]of real; i:integer; begin clrscr;...

0 голосов
197 просмотров

Program z6_2;
uses crt;
const n=6;
var a:array[1..6]of real;
i:integer;
begin
clrscr;
Writeln('введите элемент массива');
for i:=1 to 6 do readln (a[i]);
if min min:=a[i];
writeln ('min=',min:7:3);
Repeat until keypressed;
end.
Подскажите где ошибка В Pascal
Текст: Составить программу, которая выводит на экран минимальный элемент массива Х и его индекс Х={1, 3, 5, 2, -12, 0}.


Информатика (12 баллов) | 197 просмотров
Дан 1 ответ
0 голосов

Uses  crt;
var  a: array[1..6]of integer; 
 i, min: integer;
begin 
clrscr; 
min := maxInt; 
Writeln('введите элементы массива'); 
for i := 1 to 6 do  
      begin   
         readln(a[i]);   
         if  (min > a[i]) then min := a[i];  
      end; 
writeln('min=', min); 
repeat until keypressed;
end.

(724 баллов)