Написать программу 1. в которой элементы двумерного массива равны сумме квадратов...

0 голосов
41 просмотров

Написать программу 1. в которой элементы двумерного массива равны сумме квадратов индексов, 2. которая циклически сдвигает заданный одномерный массив на один элемент вправо (при этом последний элемент оказывается на месте первого элемента).


Информатика (113 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
  m=10;
  n=6;
var
  a:array[1..10,1..6] of integer;
  i,j:integer;
begin
  Writeln('Элементы массива');
  for i:=1 to m do
  begin
    for j:=1 to n do
    begin
      a[i,j]:=sqr(i)+sqr(j);
      Write(a[i,j]:4)
    end;
    Writeln
  end
end.

Тестовое решение:
Элементы массива
   2   5  10  17  26  37
   5   8  13  20  29  40
  10  13  18  25  34  45
  17  20  25  32  41  52
  26  29  34  41  50  61
  37  40  45  52  61  72
  50  53  58  65  74  85
  65  68  73  80  89 100
  82  85  90  97 106 117
 101 104 109 116 125 136

const
  n = 10;
var
  a: array[1..n] of integer;
  i, t: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  for i := 1 to n do
  begin
    a[i] := Random(50);
    Write(a[i]:3);
  end;
  Writeln;
  t:=a[n];
  for i:=n-1 downto 1 do a[i+1]:=a[i];
  a[1]:=t;
  Writeln('Результирующий массив');
  for i := 1 to n do Write(a[i]:3);
  Writeln
end.

Тестовое решение:
Элементы массива
 13 43 26 31  1 21 12  0 33 25
Результирующий массив
 25 13 43 26 31  1 21 12  0 33

(142k баллов)