Программирование в СИ++ ! Нужно написать программу, в которой 2 переменные типа float в...

0 голосов
109 просмотров

Программирование в СИ++ !

Нужно написать программу, в которой 2 переменные типа float в main() являются локальными, а после используются в функции, которая вычисляет квадраты этих чисел.

Пожалуйста, исправьте мои ошибки.
#include
#include
#include
#include
int function(float *pointer1, float *pointer2)
{
float ch1, ch2;
ch1 = powf(*pointer1, 2);
ch2 = powf(*pointer2, 2);
printf_s("Квадрат первого числа равен:%f\n", ch1);
printf_s("Квадрат второго числа равен:%f\n", ch2);
system("pause");
return(0);
}

int main()
{
setlocale(LC_ALL, "RUS");
float a, b;
float *pointer1;
float *pointer2;
printf_s("Введите первое число:");
scanf_s("%f", &a);
printf_s("Введите второе число:");
scanf_s("%f", &b);
pointer1 = &a;
pointer2 = &b;
function(&a,&b);
}

+ Напишите программу с возвратом значений


Информатика (256 баллов) | 109 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
Можно вот так, например (проверено в Dev C++):

#include
#include
using namespace std;
int function(float *pointer1, float *pointer2)
{
float ch1, ch2;
ch1 = powf(*pointer1, 2);
ch2 = powf(*pointer2, 2);
cout<<"Квадрат первого числа равен:"<<ch1<<endl;<br>cout<<"Квадрат второго числа равен:"<<ch2<<endl;<br>return(0);
}

int main()
{
setlocale(LC_ALL, "RUS");
float a, b;
float *pointer1;
float *pointer2;
cout<<"Введите первое число:";<br>cin>>a;
cout<<"<span>Введите второе число:";
cin>>b;
pointer1 = &a;
pointer2 = &b;
function(&a,&b);
system("PAUSE");
}


(142k баллов)
0

Благодарю :)

0

Пожалуйста