Напишите программу ** паскале. В двумерном массиве Z[1..5,1..5]найти наименьший элемент...

0 голосов
49 просмотров

Напишите программу на паскале. В двумерном массиве Z[1..5,1..5]найти наименьший элемент среди элементов вспомогательной(побочной) диагонали


Информатика (53 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var Z:array[1..5,1..5] of real;

   i, j: integer;

   min: real;

 

begin

   for i := 1 to 5 do

      for j := 1 to 5 do

         readln(Z[i,j]);

   min := Z[1,5];

   for i := 2 to 5 do

      if (min > Z[i,6-i]) then

         min := Z[i,6-i];

   writeln("Min value is ",min)

end.

 

(148k баллов)