Ребят, помогите пожалуйста по Паскалю. 1. Написать программу, которая вводит...

0 голосов
40 просмотров

Ребят, помогите пожалуйста по Паскалю.

1. Написать программу, которая вводит последовательность вещественных чисел, состоящую из N элементов, и определяет, является ли эта последовательность возрастающей.

2. Дан целочисленный массив размерности N. Необходимо "сжать" массив, выбросив из него каждый второй элемент. Дополнительный массив использовать нельзя.


Информатика (42 баллов) | 40 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var a:array[1..1000]of longint;
n,i,kol:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n-1 do
if a[i]if kol=n then write('vorast') else writeln('net');
end.

 

 

var a:array[1..1000]of longint;
n,i:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if i mod 2 <>0 then write(a[i],' ');
end.

(14.6k баллов)