Программа в Паскаль Напишите программу, которая возводит введенное число в степень 10,...

0 голосов
406 просмотров

Программа в Паскаль
Напишите программу, которая возводит введенное число в степень 10, используя только четыре операции умножения.
Входные данные
Входная строка содержит единственное вещественное число в диапазоне от 0 до 8.

Выходные данные
Нужно вывести 10-ю степень полученного числа с тремя знаками в дробной части.


Информатика (193 баллов) | 406 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var A,B:real;
Begin
Read(A);
B:=A*A;
B:=B*B;
B:=B*A;
B:=B*B;
Write(A,'^10 = ',B:0:3);
End.

0

Большое спасибо, Не могли бы вы помочь мне с ещё одним заданием? Найдите его на моём профиле.