Помогите пожалуйста написать программу в pascal

0 голосов
49 просмотров

Помогите пожалуйста написать программу в pascal


image

Информатика (81 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,d,max:integer; 
       begin     
           readln(a);               
               while a>0 do                   
                   begin                           
                         d:=a mod 4;                           
                                if d>max then                                 
                                      max:=d;                           
                        a:=a div 4;                                                
                  end;               
writeln(max);     
end.

(9.6k баллов)