Напишите программу, которая вводит два целых числа и находит их произведение, не...

0 голосов
98 просмотров

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными (паскаль авс)


Информатика (16 баллов) | 98 просмотров
Дано ответов: 2
0 голосов

UPD
__________
Var
a,b,s,i:integer;
begin
readln(a,b);
if a <> b then
for i:=1 to abs(b) do s:=s+a
else for I:=1 to abs(b) do s:=s+a;
if (a<0) and (b<0) then s:=abs(s)<br>else if b<0 then s:=-s;<br>writeln(s);
end.

(1.3k баллов)
0

Спасибо ^^

0

-77 * (-11) = 0 ? Да-ну

0 голосов

Var A,B,i,S:integer;
Ch:Char;
Begin
S:=0;
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
if ((A<0)and(B>0))or((A>0)and(B<0)) then Ch:='-';<br>A:=Abs(A);
B:=Abs(B);
For i:= 1 to A do
 S:=S+B;
WriteLn(Ch,S)
End.

(671 баллов)