Напишите программу ** паскале определения суммы цифр числа. Укажите является ли...

0 голосов
38 просмотров

Напишите программу на паскале определения суммы цифр числа. Укажите является ли полученный результат четным числом.


Информатика (12 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

var

  a, c : integer;

begin

  read (a);

  c := 0;

  while a > 0 do

  begin

    c := c + a mod 10;

    a := a div 10;

  end;

  writeln (c);

  if c mod 2 = 0 then write ('Четное') else write ('Нечетное');

end.

 

(4.6k баллов)