составить программу для :подсччета всех значений функции y=x^2-2x ** отрезке [-2;2] с...

0 голосов
29 просмотров

составить программу для :подсччета всех значений функции y=x^2-2x на отрезке [-2;2] с шагом h=0.5

и блоксхему


Информатика (15 баллов) | 29 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var y,x:real;

begin

x:=-2;

while x <= 2 do begin</p>

y:=sqr(x)-2x;{Считаем значение функции}

writeln(y);{Выводим значение функции}

x:=x+0.5;{Наш шаг цикла}

end;

end.

(200 баллов)