Ввести два целочисленныхмассива − по 10 элементов в каждом. Сформировать новый массив, **...

0 голосов
233 просмотров

Ввести два целочисленныхмассива − по 10 элементов в каждом. Сформировать новый массив, на четных местах которого будут элементы с нечетными индексами из первого массива, а нанечетных – с четными индексами из второго.Написать программу на паскале


Информатика (15 баллов) | 233 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Скрин с результатом работы программы прикрепил.

var a:array[1..10] of integer;
b:array[1..10] of integer;
c:array[1..10] of integer;
i:integer;
begin
write ('Введите массив 1: ');
for i:=1 to 10 do
read (a[i]);
WRITELN;
write ('Введите массив 2: ');
for i:=1 to 10 do
read (b[i]);
WRITELN;
WRITELN;
write ('Массив 3: ');
for i:=1 to 10 do
begin
if i mod 2 <> 0 then c[i]:=b[i+1];
if i mod 2 = 0 then c[i]:=a[i-1];
write (c[i],' ');
end;
end.


image
(10.7k баллов)
0

спасибо,не можете еще с этим помочь?(на паскале)В произвольной матрице - отсортировать по убыванию элементы последовательности, расположенные после второго отрицательного числа