Написать программу, которая выводит синусы и косинусы. ** языке Си. Заранее спасибо

0 голосов
78 просмотров

Написать программу, которая выводит синусы и косинусы. На языке Си. Заранее спасибо


Информатика (29 баллов) | 78 просмотров
Дано ответов: 2
0 голосов

1) Си-для начала  переменные нужно в начало функции объявлять. Если компилятор у тебя си как бы сказать си-шный,тои файл будет тоже си-шный
2)Самым первым аргументом для синуса и косинуса и формула пов(pow)будет вещественное число.
Так,косинус  и синус:
 cos(Xnumber,4) 
У функции синус и косинус только один параметр, а у pow совсем наоборот. 
 double Xnumber; и другие
I)все переменные нужно объявить , как double.  

Читать нужно будет так:
scanf("%lf", &Xnumber);
 тебе нужна для пов(pow)?
если да?,то вот:
Пов(pow)pow(cos(Xnumber), 4) + pow(sin(Ynumber), 2) + 1.0 / 4 * pow(sin(2*Xnumber), 2) - 1;
Вроде все,если понял(а),а если нет,то пиши в сообщение,и спрашивай,что не понятно
 

(342 баллов)
0 голосов

#include < iostream >    /* Подключаем библиотеку, чтоб работали функции cout, cin */
#include < cmath >    /*Подкючаем библиотеку, чтоб работали функции cos, pi */
#define PI 3.14159265   /*Задаем сколько у нас будет значит число ПИ */
using namespace std;

main (){  
         float a, result;   /*Вводим 2 переменные - действительные числа: одно - число градусов угла, второе - полученный результат*/
         cout << <span>"Vvedite znachenie ugla" << endl;<br>          cin >> a;   /* Вводим значение угла с клавиатуры*/
         result = cos (a*PI/180);    /*высчитываем значение косинуса, переводя значениезаданного угла в радианы */
         cout << <span>"Kosinus "<< a <<<span> " raven " << result; <span>   /*Выводим полученное на экран */
         return 0;    /*Возвращает нулевое значение */
}

(1.1k баллов)