Помогите написать программу ** PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N. ...

0 голосов
42 просмотров

Помогите написать программу на PascalABCNET
ВХОДНЫЕ ДАННЫЕ

Задано натуральное число N.
ВЫХОДНЫЕ ДАННЫЕ

Определите количество нулей в его записи.


image

Информатика (94 баллов) | 42 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  n:string;
  i,k:integer;
begin
  Writeln('Введите число: '); Read(n);
  k:=0;
  for i:=1 to length(n) do
    if n[i]='0' then Inc(k);
  Writeln('Количество нулей в числе равно ',k)
end.

Тестовое решение:
Введите число:
2053006204
Количество нулей в числе равно 4

(142k баллов)