Помогите написать программу ** PascalABCNETВХОДНЫЕ ДАННЫЕДана последовательность...

0 голосов
49 просмотров

Помогите написать программу на PascalABCNET

ВХОДНЫЕ ДАННЫЕ

Дана последовательность натуральных чисел, завершающаяся нулем.

ВЫХОДНЫЕ ДАННЫЕ

Определите, какое наибольшее количество подряд идущих элементов этой последовательности равны друг другу.Числа, идущие после нуля, считывать не нужно.


image

Информатика (94 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  n,npred,maxs,nseq:integer;
begin
  Writeln('Вводите натуральные числа, 0 - конец ввода');
  maxs:=0; npred:=-32768; nseq:=1;
  repeat
    Read(n);
    if n<>0 then begin
      if n=npred then Inc(nseq)
      else begin nseq:=1; npred:=n end;
      if maxs    end
  until n=0;
  Writeln('Наибольшая длина последовательности равна ',maxs)
end.

Тестовое решение:
Вводите натуральные числа, 0 - конец ввода
1
5
5
0
Наибольшая длина последовательности равна 2

(142k баллов)