Помогите написать программу ** PascalABCNET ВХОДНЫЕ ДАННЫЕ Дано целое число A и целое...

0 голосов
40 просмотров

Помогите написать программу на PascalABCNET

ВХОДНЫЕ ДАННЫЕ

Дано целое число A и целое неотрицательное число i.
ВЫХОДНЫЕ ДАННЫЕ

Выведите значение i-ого бита числа A (0 или 1).


image

Информатика (94 баллов) | 40 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Function Dec2Bin(n:longint): string;
{ Перевод натурального десятичного n в систему счисления по основанию 2 }
var
  s: string;
begin
  s := '';
  while n > 0 do
  begin
    if Odd(n) then s:='1'+s else s:='0'+s;
    n := n div 2
  end;
  Dec2Bin := s;
end;

var
  A:longint;
  i,k:integer;
  s:string;
begin
  Write('Введите натуральное число А: '); Read(A);
  Write('Введите номер бита i (счет с 1 справа налево): '); Read(i);
  s:=Dec2Bin(A);
  k:=Length(s);
  if (i>0) and (i<=k) then Writeln('Значение бита: ',s[k+1-i])<br>  else Writeln('Неверный номер бита')
end.

Тестовое решение:
Введите натуральное число А: 37
Введите номер бита i (счет с 1 справа налево): 5
Значение бита: 0

(142k баллов)
0

Partial Solution. Your score is = 22, 22/50 tests passed

0

Меня меньше всего волнует чья-то там автоматическая оценка. Задача решена и протестирована на нескольких вариантах исходных данных. Если есть конкретная ошибка - укажите её