Составьте программу, которая находит большее из 3 заданных различных целых чисел и...

0 голосов
80 просмотров

Составьте программу, которая находит большее из 3 заданных различных целых чисел и выводит его на экран
просто написать нужно
8 класс


Информатика (20 баллов) | 80 просмотров
0

на каком тебе языке?

0

это да

0

задача не сложная

0

ладно напишу в паскале

0

понятно

0

можно и устно её решение сказать

0

Спасибо)

Дан 1 ответ
0 голосов

Var    a1, a2, a3, max: integer;
 begin 
  writeln('a1='); 
   readln(a1);
    writeln('a2='); 
   readln(a2);   
 writeln('a3='); 
  readln(a3);  
   if a1 > a2 then 
       max := a1    else 
      max := a2;  
  if a3 > max then   
    max := a3;    
writeln ('Максимальное из них: ', max);
 readln;
end.

0

у меня уже такое было

0

Не ошибка это, там всё только от версии паскаля зависит...

0

по сути этот оператор используется для того что бы экран с ответом не исчезал, но результат программы можно посмотреть во вкладке debug->output

0

не знаю когда я кодил в free pascal у учительницы при проверке моя программа на одном из наборов повисла

0

А можно еще одну задачу?

0

какую

0

Составьте программу, которая определяет является ли сумма цифр введенного числа четным числом

0

Спасибо)