написать программу для pascal: выиснить является ли заданное число совершенным?

0 голосов
68 просмотров

написать программу для pascal: выиснить является ли заданное число совершенным?


Информатика (82 баллов) | 68 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

uses
SysUtils;

var
n,m,i:integer;
begin
readln(n);
m:=0;
for i := 1 to n-1 do
if m > n then break else
if (n mod i = 0) then m:=m+i;
if m=n then writeln('Yes') else
writeln('No');
end.

(248 баллов)
0 голосов

Program Pr1;
uses crt;
var i,n,a:integer;
Begin
clrscr;
readln(n);
i:=1; a:=0;
while i<=n do begin<br> if (n mod i=0) and (i<>n) then a:=a+i;
inc(i);
end;
if a=n then writeln('YES')
else writeln('No');
end.

(895 баллов)