Procedure RND(a,b,n:integer);
var
i:integer;
begin
Randomize;
for i:=1 to n do Write(Random(b-a+1)+a,' ')
end;
var
a,b,n:integer;
begin
Write('Задайте интервал для генерирования чисел ');
Read(a,b);
Write('Укажите количество случайных чисел: '); Read(n);
RND(a,b,n)
end.
Тестовое решение:
Задайте интервал для генерирования чисел -5 10
Укажите количество случайных чисел: 30
-4 1 4 -1 3 -4 9 1 5 -1 -1 9 1 -2 -5 -2 1 -2 2 -3 2 -4 7 10 -3 3 10 5 6 -1