Pascal ABC 8 класс, помогите срочно••• 1.Составить программу, которая выводит...

0 голосов
47 просмотров

Pascal ABC 8 класс, помогите срочно•••

1.Составить программу, которая выводит произведение целых чисел от a до 20. 2.Даны натуральные числа от 20 до 50, вывести те, которые делятся на 3, но не делятся на 5.


Информатика (12 баллов) | 47 просмотров
0

У Вас Pascal ABC или PascalABC.Net ?

0

ABC

0

Это плохо.

Дан 1 ответ
0 голосов
Первая:
program qwer;
uses crt;
var pr: double;
i, a: integer;
Begin
write('Введите число а: ');
readln(a);
pr := 1;
for i := a to 20 do
pr := pr * i;
writeln(pr);
End.
Вторая:
program qwer;
uses crt;
var i: integer;
Begin
for i := 20 to 50 do
 if (i mod 3 = 0) and (i mod 5 <>0) then writeln(i);
End.
(505 баллов)
0

А вторая?

0

Пишу

0

Вопрос, Вы свою программу когда написали, пробовали её проверить? Введите, например, а=1 и посмотрите на ответ

0

Для a<14 программа врет из-за арифметического переполнения.

0

Информация, не относящаяся к текущему вопросу или ответу считается спамом

0

Теперь верно?

0

Зачем спрашиваете, когда сами знаете ответ? Раз ушли на плавающую точку, конечно верно.

0

Но это же и сначала было понятно что 20! даст переполнение на longint