Dev_c++ Напишите программу, которая вводит координаты двух точек ** числовой оси и...

0 голосов
150 просмотров

Dev_c++
Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.


Информатика (64 баллов) | 150 просмотров
Дан 1 ответ
0 голосов

#include                 
#include ;               

using namespace std;               
int main(int argc, char* argv[])               
{               
    setlocale(LC_ALL, "Russian");
       double x1,x2,y1,y2,distance;             
 
        cout <<"Введите координату x1:";             <br>        cin>>x1;                    
        cout <<"Введите координату y1:";             <br>        cin>>y1;            
        cout <<"Введите координату x2:";             <br>        cin>>x2;            
        cout <<"Введите координату y2:";             <br>        cin>>y2;                             
        distance=sqrt(pow((x2-x1),2)+pow((y2-y1),2));      // формула для вычисления расстояния
        cout<<"Расстояние между двумя точками:"<<distance<<endl;  <br>        system("pause");
}

(868 баллов)