Написать программу в паскале. Дана площадь S круга. Найти его диаметр D и длину L...

0 голосов
128 просмотров

Написать программу в паскале.
Дана площадь S круга. Найти его диаметр D и длину L окружности,
ограничивающей этот круг, учитывая, что L = 2·π·R, S = π·R^2

. В качестве
значения π использовать 3.14.


Информатика (54 баллов) | 128 просмотров
Дан 1 ответ
0 голосов

Program qwer;
uses crt;
var s, r, d, l: real;
Begin
write('Площадь круга: ');
readln(s);
r := sqrt(s / 3.14);
d := r * 2;l := 2 * 3.14 * r;
writeln('Диаметр: ',d);
writeln('Длина окружности: ',l);
End.

(505 баллов)