Паскаль!!! срочно напишите программу, только используйте цикл. Найти сумму квадратов всех...

0 голосов
77 просмотров

Паскаль!!! срочно напишите программу, только используйте цикл.

Найти сумму квадратов всех целых чисел от a до b (значения a и b вводятся с клавиатуры, b≥a)


Информатика (381 баллов) | 77 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

var

  i, a, b, sum : integer;

begin

  read (a, b);

  sum := 0;

  for i := a to b do

    sum := sum + sqr (i);

  writeln (sum);

end.

(4.6k баллов)
0 голосов

program ex1;

var

  i, a, b, otvet : integer;

begin

  read (a, b);

  otvet := 0;

  for i := a to b do

    otvet :=otvet +i*i ;

  writeln ('otvet=',otvet);

end.

(57 баллов)