Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает **...

0 голосов
60 просмотров

Помогите по программе paskal :

1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат


Информатика (24 баллов) | 60 просмотров
Дан 1 ответ
0 голосов

1)

program test;
var number: integer;
begin
   write('Enter the number: ');
   readln(number);

   number:=abs(number)-2;
   writeln(number);

   readln;
end.

 

2)

program test;
var number, temp: integer;
begin
   write('Enter the number: ');
   readln(number);

   temp:=number mod 10;
   writeln(temp, '^2=', temp*temp);

readln;
end.

(2.0k баллов)