Питон Напишите программу, выводящую все биты 8-битного числа Входные данные Дано число A...

0 голосов
210 просмотров

Питон
Напишите программу, выводящую все биты 8-битного числа

Входные данные
Дано число A (0≤A≤255).

Выходные данные
Выведите число A в битовой форме: 8 бит, старшие биты слева, младшие – справа.

Примеры
входные данные
5
выходные данные
00000101


Информатика (41 баллов) | 210 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
Вот один из вариантов:

s=str(bin(int(input("Введите число от 0 до 255: "))))[2:].rjust(8,"0")
print(s)

Объяснения:
1) input("Введите число от 0 до 255: ") организует ввод символьной строки
2) int() преобазует введенную строку к целому числу
3) bin() преобразует целое число к строке с его двоичным извображением и слева добавляет признак "ob"
4) [2:] - срез строки обеспечивает отсечение левых двух символов (т.е. "0b")
5) .rjust - метод, добавляющий в строку слева символы-заполнители (в нашем случае "0") до указанной длины (8).
6) и в переменную s заносится полученный результат

Тестовые решения:

Python 3.4.2 (v3.4.2:ab2c023a9432, Oct  6 2014, 22:15:05) [MSC v.1600 32 bit (Intel)] on win32
Type "copyright", "credits" or "license()" for more information.
>>> ================================ RESTART ================================
>>>
Введите число от 0 до 255: 0
00000000

Введите число от 0 до 255: 255
11111111

Введите число от 0 до 255: 74
01001010
(142k баллов)
0 голосов

A = int(input())
s = ""
for i in range(8):
    s = s[:i] + str(a % 2) + s[i:]
    a = a // 2
for i in range(len(s)):
    print(s[len(s)-i-1],end='')

(1.2k баллов)