Составьте программу, выводящую ** экран все делители числа х. Число x введите с...

0 голосов
27 просмотров

Составьте программу, выводящую на экран все делители числа х. Число x введите с клавиатуры. Пример ввода: 12
Пример вывода: 1 2 3 4 6 12
Помогите пожалуйста!!!!!!!


Информатика (22 баллов) | 27 просмотров
Дан 1 ответ
0 голосов

Var n,i:integer;
begin
readln(n);
for i:=1 to n do
if n mod i = 0 then write(i,' ');
readln;
end.

(153 баллов)
0

спасибо !!!!!

0

:D