Даю 100 баллов. Напишите программу, которая содержит тест (Pascal) Не забудьте сделать...

0 голосов
111 просмотров

Даю 100 баллов. Напишите программу, которая содержит тест (Pascal)
Не забудьте сделать заставку.
Тест "Приятно ли с вами общаться?"
Если человек общителен, то это еще не значит, что с ним приятно разговаривать. Есть люди, которые своей общительностью надоедают каждому буквально с первых минут разговора. Посмотрите внимательно, разве мало вокруг таких людей? А вы приятный собеседник?
1) Вы любите больше слушать, чем говорить?
2) Вы всегда можете найти тему для разговора, даже с незнакомым человеком?
3) Вы всегда внимательно слушаете собеседника?
4) Любите ли вы давать советы?
5) Если тема разговора вам не интересна, станете ли показывать это собеседнику?
6) Раздражаетесь, когда вас не слушают?
7) У вас есть собственное мнение по любому вопросу?
8) Если тема разговора вам не знакома, станете ли вы ее развивать?
9) Вы любите быть центром внимания?
10) Есть ли хотя бы три предмета, по которым вы обладаете достаточно прочными знаниями?
11) Вы хороший оратор?
Если вы положительно ответили на вопросы 1,2,3,4,5,6,7,8,9,10,11, то можете засчитывать себе по одному баллу за каждый из них.
А теперь посчитаем:
1-3 балла: Трудно сказать, то ли вы молчун, из которого не вытянешь ни слова, то ли настолько общительны, что вас стараются избегать, но факт остается фактом: общаться с вами далеко не всегда приятно, а порой даже тяжело. Вам бы следовало над этим задуматься.
4-9 баллов: Вы, может быть, и не слишком общительный человек, но почти всегда внимательный и приятный собеседник. Вы можете быть и весьма рассеянным, когда не в духе, но не требуете от окружающих в такие минуты особого внимания к вашей персоне.
10--11 баллов: Вы, наверное, один из самых приятных собеседников, друзья не могут без вас обойтись


Информатика (4.9k баллов) | 111 просмотров
0

Всм с заставкой

0

Типо чтоб красиво было

0

Еще надо ?

0

А чуваку надо с ними, типа чтобы красиво оформить

0

тебе чуть выше написали, заставка это writeln

0

делать ?

0

я могу сделать но без заставок и там у подобное

0

Звиняй, друг, но модератор почему-то удалил мой ответ. Так что пиши сам. :)

0

Написать написала но в ответ тут она копируется с рекодировкой, щас че-нибудь придумаю, переписывать лень

0

Writeln ('*********')

Дано ответов: 2
0 голосов
Правильный ответ

Program test;
var a,b,c,d,e,f,g,h,j,k,l,s: integer;
begin
s:=0;
writeln ('Тест "Приятно ли с вами общаться?" Если человек общителен, то это еще не значит, что с ним приятно разговаривать. Есть люди, которые своей общительностью надоедают каждому буквально с первых минут разговора. Посмотрите внимательно, разве мало вокруг таких людей? А вы приятный собеседник?');
writeln ('1) Вы любите больше слушать, чем говорить?');
writeln ('1 да, 2 нет');
readln (a);
if a=1 then s:=s+1 else s:=s+0;
writeln ('2) Вы всегда можете найти тему для разговора, даже с незнакомым человеком?');
writeln ('1 да, 2 нет');
readln (b);
if b=1 then s:=s+1 else s:=s+0;
writeln ('3) Вы всегда внимательно слушаете собеседника? ');
writeln ('1 да, 2 нет');
readln (c);
if c=1 then s:=s+1 then s:=s+0;
writeln ('4) Любите ли вы давать советы?');
writeln ('1 да, 2 нет');
readln (d);
if d=1 then s:=s+1 else s:=s+0;
writeln ('5) Если тема разговора вам не интересна, станете ли показывать это собеседнику?');
writeln ('1 да, 2 нет');
readln (e);
if e=1 then s:=s+1 else s:=s+0;
writeln ('6) Раздражаетесь, когда вас не слушают?');
writeln ('1 да, 2 нет');
readln (f);
if f=1 then s:=s+1 else s:=s+0;
writeln ('7) У вас есть собственное мнение по любому вопросу?');
writeln ('1 да, 2 нет');
readln (g);
if g=1 then s:=s+1 else s:=s+0;
writeln ('8) Если тема разговора вам не знакома, станете ли вы ее развивать?');
writeln ('1 да, 2 нет');
readln (h);
if g=h then s:=s+1 else s:=s+0;
writeln ('9) Вы любите быть центром внимания?');
writeln ('1 да, 2 нет');
readln (j);
if j=1 then s:=s+1 else s:=s+0;
writeln ('10) Есть ли хотя бы три предмета, по которым вы обладаете достаточно прочными знаниями?');
writeln ('1 да, 2 нет');
readln (k);
if k=1 then s:=s+1 else s:=s+0;
writeln ('11) Вы хороший оратор?');
writeln ('1 да, 2 нет');
readln (l);
if l=1 then s:=s+1 else s:=s+0;
writeln ('Ваши баллы - ', s);
writeln ('1-3 балла: Трудно сказать, то ли вы молчун, из которого не вытянешь ни слова, то ли настолько общительны, что вас стараются избегать, но факт остается фактом: общаться с вами далеко не всегда приятно, а порой даже тяжело. Вам бы следовало над этим задуматься. 4-9 баллов: Вы, может быть, и не слишком общительный человек, но почти всегда внимательный и приятный собеседник. Вы можете быть и весьма рассеянным, когда не в духе, но не требуете от окружающих в такие минуты особого внимания к вашей персоне.10-11 баллов: Вы, наверное, один из самых приятных собеседников, друзья не могут без вас обойтись');
end.

(52 баллов)
0

Щас сама проверю

0

then на else

0

ошибка в 17 строке

0

Я уже все исправила, пробуй.

0

Я тебе другой норм код дам )

0

я жду

0

я знаю что укажется строка

0

Все, у меня все пошло, нашла всего две ошибки, и то даже не ошибки, а опечатки при копировании)

0

Скачай PascalABC и нажми проиграть, там укажется строка, символ по счету и в чем состоит ошибка

0

Ну, извини за косяки. :) Давно не писала уже, так, хоть вспомнила что к чему

0 голосов

Тут код.
Если что то не работает пиши и желательно в лс.

(514 баллов)