Напишите программу, которая вводит натуральные числа a и b и вводит все простые числа в...

0 голосов
42 просмотров

Напишите программу, которая вводит натуральные числа a и b и вводит все простые числа в диапазоне от a до b.

Спасибо :)


Информатика (15 баллов) | 42 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    a, b, i, j, found: integer;

begin
    readln(a, b);
    
    for i := a to b do
    begin
        found := 1;
        
        for j := 2 to round(sqrt(i + 1)) do
        begin
            found := found * (i mod j);
            if found = 0 then break;
        end;
        
        if found <> 0 then write(i, ' ');
    end;
end.

(55.0k баллов)