написать программу,каторая выделит все запятые из строки st начиная с позиции р

0 голосов
48 просмотров

написать программу,каторая выделит все запятые из строки st начиная с позиции р


Информатика (12 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

 {Программа на Free Pascal}

Var st:string;

z,p,i:integer;

begin

z:=0;

readln(st);{Считываем строку}

read(p);{Считываем позию}

for i:=p to length(st) do if(st[i] = ',') then inc(z);{Пробегаемся по строке с позиции p и ищем ,}

writeln(z);{Выводим кол-во найденых запятых}

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

(200 баллов)